backtotop

Categories: Дата_Время

Как перевести время в число в Excel

Что будет если из 12-00 вычесть 21-00 в Excel?  По идее, если время — это число, то должно получиться отрицательное число. Но, как показано на картинке, будет возвращаться значение = множеству знаков ##### (диез, решетка или хеш). Как сделать чтобы отрицательное время в Excel отображалось красиво и корректно? Как использовать отрицательное время в последующих вычислениях формулами.

Отрицательное время в excel

1 способ. Отрицательное время в Excel. Убрать копированием

Просто скопируйте значение с множеством #, как значение в другую ячейку. Можно использовать специальную вставку.

Или измените формат на числовой. Как это сделать можно прочитать в этой статье.

2 способ. Простые формулы

Просто умножьте отрицательное время на -1. Или добавьте еще и функцию =ЕСЛИ(), как показано на картинке ниже

Если значение ячейки <0, то значение * -1

=ЕСЛИ(B3<0;B3*-1;B3)

Так же можно, в условии поменять местами меньшее и большее время.

Отрицательное время в excel

3 способ. Изменить формат отображения времени

Изначально Excel использует систему дат, начинающуюся с 1 января 1900 года, можно переключить на систему использования 1904. Зайдите Файл — Параметры — Параметры Excel — Дополнительно — раздел «При пересчете этой книги» — Использовать систему дат 1904.

Отрицательное время в Excel

Отрицательные значения времени будут отображаться правильно. К сожалению, этот способ может ввести ваших коллег в недоумение, поскольку, на другом компьютере без включения галочки, этот файл будут выглядеть опять же неверно. Если готовы всем объяснять, то этот способ для вас :)

Не забудьте снять галочку, после проведения операций — ведь теперь такая система дат распространена на все ваши книги Excel!

4 способ. Функция ТЕКСТ

Функцию =ТЕКСТ тоже удобно использовать в таких случаях. Например:

=ТЕКСТ(ABS(A2-A1);"-ч:мм:сс")

где функция ABS возвращает модуль числа (т.е. его положительное значение). А функция ТЕКСТ уже преобразует число в нужный формат «-ч:мм:сс».  Эта формула хороша тем, что можно возвратить именно отрицательное значение в формате времени.

Но это не самое лучшее решение, т.к. использовать его в последующих формулой не получится (формула будет считать данные в ячейке текстом)- для верного отображения лучше всего переводить значение в число (1ый способ).

Отрицательное время в excel

Пример

 

Поделитесь нашей статьей в ваших соцсетях:

(Visited 2 138 times, 39 visits today)
Как перевести время в число в Excel

Комментарии:

К этой записи пока нет комментариев. Возможно вы будете первым?

Оставьте ваш комментарий здесь:

You have to agree to the comment policy.

шестнадцать − семь =