backtotop

Categories: Дата_Время

Что будет если из 12-00 вычесть 21-00 в Excel?  По идеи, если время — это число, то должно получиться отрицательное число. Но, как показано на картинке, будет возвращаться значение множество знаков ### (диез или хеш). Как сделать отрицательное время в Excel отображалось красиво?

Отрицательное время в excel

1 способ. Отрицательное время в Excel. Убрать копированием

Просто скопируйте значение с множеством #, как значение в другую ячейку.

Или измените формат на числовой. Как это сделать можно прочитать в этой статье

2 способ. Простые формулы

Просто умножьте на -1. Если добавить еще и функция =ЕСЛИ(), как показано на картинке ниже

Если значение ячейки <0, то значение * -1

Так же можно, в условии поменять местами меньшее и большее время.

Отрицательное время в excel

3 способ. Изменить формат отображения времени

Изначально Excel использует систему дат, начинающуюся с 1 января 1900 года, можно переключить на систему использования 1904. Зайдите Файл — Параметры — Параметры Excel — Дополнительно — раздел «При пересчете этой книги» — Использовать систему дат 1904.

Отрицательное время в Excel

Отрицательные значения времени будут отображаться правильно. Но это не самый лучший вариант, поскольку, на другом компьютере без включения галочки, этот файл будут выводиться неверно.

Не забудьте снять галочку, после проведения операций — ведь теперь такая система дат распространена на все ваши книги Excel!

4 способ. Функция ТЕКСТ

Функцию =ТЕКСТ удобно использовать в таких случаях. Например:

=ТЕКСТ(ABS(A2-A1);»-ч:мм:сс»)

где функция ABS возвращает модуль числа. Эта формула хороша тем, что можно возвратить именно отрицательное значение в формате времени.

Но это не самое лучшее решение, чтобы использовать его в последующих вычислениях — для верного отображения лучше всего переводить значение в число (1ый способ).

Отрицательное время в excel

Пример

Поделитесь нашей статьей в ваших соцсетях:


Комментарии:

К этой записи пока нет комментариев. Возможно вы будете первым?

Оставьте ваш комментарий здесь:

You have to agree to the comment policy.

три × 5 =