backtotop
Сортировка-формулой

Categories: Excel

Как сортировать в Excel знают практически все. Но Очень часто необходима именно сортировка формулой, поскольку результаты вычисления участвуют затем в последующих расчетах. Как это сделать?

Для такой сортировки стоит выделить два случая

— Сортировка числовых значений

— Сортировка текста

Сортировка формулой числовых значений

В серых столбцах показано, какие формулы надо применять. Немного подробнее

1. Сперва отсортируем именно числа, для этого применяется хорошая комбинация функций =НАИМЕНЬШИЙ(A:A;СТРОКА()-1). Где функция НАИМЕНЬШИЙ() ищет значения в столбце А и возвращает нужное число по счету (т.е. если после точки с запятой поставить 1, вернет самое меньшее — первое значение в массиве), мы же используем нумерацию строк, функция СТРОКА() считает как раз номер строки, вычитаем единицу, поскольку массив начался со второй строки.

=НАИМЕНЬШИЙ(A:A;СТРОКА()-1)

2. Для каждого числа проставим соответствующие фамилии функцией =ВПР() в столбце Е. Для простоты понимания скачайте пример, а для закрепления сделайте ВПР для имен.

Сортировка формулой чисел

Сортировка формулой текста 

С текстом функция НАИМЕНЬШИЙ() уже не работает. Здесь лучше всего применить конструкцию с функцией =СЧЁТЕСЛИ()

=СЧЁТЕСЛИ($H$1:$H$5;"<"&H2)+СЧЁТЕСЛИ($H$2:H2;"="&H2)

Где первое выражение ищет в диапазоне $B$8:$B$12 все значения не равные Фамилии в этой строке, второе выражение приплюсовывает значение при нахождении значений равных нужной фамилии.

Обращаю внимание, что во втором выражении диапазон изменяется (т.е. закреплена только первая ячейка) в следующих строках диапазон будет расширяться.

Т.е. мы нашли порядковые номера каждой фамилии. Столбец J.

Проставлем порядковые номера от 1 и дальше в столбце K.

Теперь заВПРим соответствующие значения в столбце L.

Сортировка формулой

Ничего сложного быть не должно, скачайте файл пример:

Пример для двух вариантов

Если будут вопросы смело пишите в комментарии.

  .

Comments

Там нет комментариев

Leave a Comment:

Ваш e-mail не будет опубликован. Обязательные поля помечены *

четырнадцать − двенадцать =