backtotop

Как правильно должна быть заполнена таблица в Excel? Мы знаем, что форма отчетов, так называемой иерархией (особенно в 1С). Отчет по форме иерархией — это форма когда определенный признак не заполнен в каждой строке таблицы. Такая форма мешает правильной обработке данных в Excel, т.к. программа не видит данные для каждой строки. Посмотреть  пример можно на картинке в столбце С, Город. Если делать сводную таблицу с отбором по столбцу С, данные по городу МСК в строках 3 и 4 не попадут в отчет. Необходимо преобразовать данные столбца C в вид столбца Е или D. Так как заполнить пустые ячейки в таблице Excel, чтобы программа воспринимала их правильно?

заполнить пустые ячейки в таблице

Возьмите за правило:

Правильно заполненная таблица Excel — это таблица, где нет пустых ячеек.

Есть несколько несложных способов, как заполнить ячейки сплошными данными

  1. Как заполнить пустые ячейки в таблице? Простая формула

заполнить пустые ячейки в таблице 1

Простой функцией ЕСЛИ, можно творить страшные вещи. В данном случае формула достаточно простая, но очень эффективная.

Суть в следующем, в соседнем столбце (D), мы проверяем пустая ли ячейка в соседнем столбце (C2);

  • если ячейка пустая, то подставляем данные из предыдущей ячейки этого столбца D1;
  • если ячейка заполнена, то вставляем С2 в нашем случае МСК.
  • =ЕСЛИ(C3="";D2;C3)

Протянув формулы вниз по нужным ячейкам, получим полностью заполненный столбец D в таблице.

2. Как заполнить пустые ячейки без сложных формул

Есть один хитрый способ обойтись без формул. Может быть понятно не сразу, поэтому напишу по пунктам.

1.Выделяем весь столбец, где не заполнены все ячейки. Я скопировал столбец С в столбец Е для примера.

заполнить пустые ячейки в таблице 2

2. Заходим в меню Главная — Найти и Выделить — Выделение группы ячеек.

заполнить пустые ячейки в таблице 3

3. В открывшемся окне выбираем «пустые ячейки». Таким образом, мы выберем все пустые ячейки в столбце Е, но только в нужном диапазоне.

заполнить пустые ячейки в таблице 4

4. Теперь не торопитесь! Вы выделили все пустые ячейки и теперь для них нужно задать формулу заполненной ячейки (E2 в нашем случае) — это можно сделать записав ее в строку формул

заполнить пустые ячейки в таблице 5

5. Чтобы задать формулу для всех выделенных пустых ячеек жмем обязательно Ctrl + Enter, всё, данные заполнились.

Для обоих столбцов D и E, остались формулы в ячейках. Скопируйте этот столбец и вставьте данные как значения.

 

Пример файла можно скачать Пример. Пустые строки.

 

  .

Comments

( 2 Comments )

Ксения:

Благодарю! Это так здорово!

Отлично, мы старались ;)

Leave a Comment:

Ваш e-mail не будет опубликован. Обязательные поля помечены *

4 × 5 =