backtotop
Пустые ячейки 0

Categories: Формулы

Поиск в двумерном массиве Excel (по матрице). ВПР и ПОИСКПОЗ
Как найти номер строки и столбца в Excel?

Когда диапазон заполняется руками довольно долго бывает, что могут быть пропущены ячейки, чтобы определить есть ли такие ячейки в Excel диапазоне есть специальная функция СЧИТАТЬПУСТОТЫ (COUNTBLANK). В статье так же рассмотрены другие способы как посчитать количество пустых ячеек

Пустые ячейки не считаются многими формулами, например при расчете среднего значения, функцией СРЗНАЧ пустая ячейка не учитывается (необходимо заменить на 0). Соответственно существуют специальные формулы для подсчета именно незаполненных ячеек

Считаем количество пустых ячеек функцией СЧИТАТЬПУСТОТЫ

количество пустых ячеек

В формуле необходимо задать диапазон, как показано на картинке

=СЧИТАТЬПУСТОТЫ(A2:A6)

Такая формула выдаст значение = 3.

Считаем количество пустых ячеек функцией СЧЁТЕСЛИ

В версиях Excel ниже 2007 не было функции СЧИТАТЬПУСТОТЫ, поэтому мы часто пользовались СЧЁТЕСЛИ.

Запишем формулу для того же диапазона

=СЧЁТЕСЛИ(A2:A6;"")

Как определить пустая ли конкретная ячейка? ЕПУСТО

Важное замечание по пустым ячейкам

Если вы использовали в формулах замену на пустое значение обозначенное как «» (например, =ЕСЛИОШИБКА(A:A;»»)), то после копирования значения такой ячейки она не будет считаться пустой. Хотя на вид она выглядит как незаполненная.

Для определения только пустых ячеек применяется функция

=ЕПУСТО()

Файл пример — «как считать пустые ячейки«

Как выделить цветом пустые ячейки в Excel?

Конечно же условным форматированием. Выделяем необходимый диапазон, в верхней панели во вкладке Главная находим Условное форматирование — Создать правило…

Пустые ячейки 1

В открывшемся окне выбираем Форматировать только ячейки, которые содержат и ниже Пустые. Выбираем как нужно форматировать, по кнопке Формат… Я выбрал заливку розовым цветом, что показано в окне Образец:

Пустые ячейки 2

Ячейки выбранного диапазона окрасились цветом

Пустые ячейки 3

Если в ячейке стоит пробел, то такая ячейка уже уже не будет считаться пустой функцией СЧИТАТЬПУСТОТЫ. При этом и условное форматирование не будет выделять эту ячейку как пустую. Поиск и замену подобных ячеек можно осуществить при помощи функции Найти и заменить

Будут вопросы задавайте в комментариях!

 

Поделитесь нашей статьей в ваших соцсетях:

(Visited 5 513 times, 26 visits today)
Поиск в двумерном массиве Excel (по матрице). ВПР и ПОИСКПОЗ
Как найти номер строки и столбца в Excel?

Комментарии:

К этой записи пока нет комментариев. Возможно вы будете первым?

Оставьте ваш комментарий здесь:

You have to agree to the comment policy.

17 − 11 =