backtotop

Categories: Формулы

Функция СУММПРОИЗВ в Excel. Кто много работает с Excel, я уверен неоднократно встречался с функцией =СУММПРОИЗВ(). Как и многие, я сперва не знал о ее существовании, но как всегда оказалось, что это крайне полезная функция. Пришлось применить ее для файлов в excel 2003, хочу и для вас описать ее поподробнее:

СУММПРОИЗВ

СУММПРОИЗВ, для чего пригодится?

Итак, сначала поговорим о синтаксисе и назначении этой функции. Функция из раздела Математические, справка по ней дает достаточно скудную информацию. Постараюсь это исправить.

Состав/синтаксис, как видно на картинке простой

=СУММПРОИЗВ(массив1; [массив2]; …)

Как все же применять ее?

СУММПРОИЗВ. Простое применение

Самое простое использование, перемножение данных в массиве1 и массиве2. Например когда нужно найти величину стоимость проданных товаров. Как видите, выбираем массив Количество и массив Цена, получаем итоговую сумму продаж. Столбец D приведен для проверки

СУММПРОИЗВ

Важно понимать, что функция перемножает данные на одной строке.

Применение 2. СУММПРОИЗВ как замена СУММЕСЛИМН

Во времена Excel 2003, когда еще не было функции СУММЕСЛИМН, мы применяли функцию СУММПРОИЗВ для поиска суммированных значений показателей по нескольким определенным условиям (просто суммесли ищет только по одному условию). Вот тогда и выручали конструкции с функцией из нашей статьи

Представим, что в наши данные добавился список филиалов

СУММПРОИЗВ

И нам нужно найти сумму по филиалу номер 3. Запишем формулу в ячейку D14

=СУММПРОИЗВ(($B$2:$B$9=$B$14)*($E$2:$E$9))

Файл пример можно скачать здесь

Таких условий, вы можете записать множество, и даже брать диапазоны с других листов.

Применение 3 

Очень часто эта функция используется для промежуточных вычислений задачи линейного программирования. Об этом я напишу в ближайшее время.

Что нужно помнить и знать о функции (плохо когда не знаешь и еще забудешь;)

  • Умножать необходимо одинаковые по размерам таблицы данных
  • Если у вас Excel 2007 (или версия еще новее), думаю лучше использоваться СУММЕСЛИМН или СЧЕТЕСЛИМН
  • Когда используете ЕСЛИ внутри формулы с СУММПРОИЗВ рекомендуем использовать формулы массивов (Ctrl + Shift + Enter), чтобы Excel вас правильно понял. Но лучше найти альтернативное решение для вашего случая! Пишите в комментарии или на почту, мы обязательно поможем!

 

Поделитесь нашей статьей в ваших соцсетях:


Комментарии:

К этой записи пока нет комментариев. Возможно вы будете первым?

Оставьте ваш комментарий здесь:

You have to agree to the comment policy.

восемнадцать − 17 =